版本说明

最后更新:2024-01-10 13:01:56 | 状态:未完成

项目中相关anyline的依赖务必保持版本号一致。如果不一致会加载多个版本的anyline-core,anyline-data等基础类,不同版本的jar会注入名称相同的bean导致启动失败
如:不要anyline-data-jdbc-mysql用6.3而anyline-data-jdbc-oracle用6.2(每个jar无论源码有没有修改过,每次发版时都会发一个新版本)
spring 3.x需要jdk17支持,Tomcat也默认10.x,maven最低3.8.3
对应anyline需要8.7.1及以上版本,注意需要带jdk17后缀的,如8.7.1-jdk17-yyyyMMdd,代码稍有区别参考【jdk8>jdk17】[Tomcat8/9>Tomcat10]

项目开发过程中可以使用私服或中央库上的快照版本 如:8.7.1-SNAPSHOT参考【启用maven中央库的SNAPSHOT版本依赖

项目上线时务必要换成发行版本 如8.7.1-yyyyMMdd(SNAPSHOT版本每天更新,一旦出了问题不要影响生产环境)
参考【releases版本说明
第一次搭建的简易测试环境注意【以provided形式依赖的库

中央最新版本查看:
https://mvnrepository.com/artifact/org.anyline/anyline-core

https://central.sonatype.com/artifact/org.anyline/anyline-core

https://repo.maven.apache.org/maven2/org/anyline/anyline-core/

快照版本在这里查看,主要看最后的
lastUpdated确认一下最新日期

https://oss.sonatype.org/content/repositories/snapshots/org/anyline/anyline-core/maven-metadata.xml

开发过程一般什么快照版本,为了保证快照版本的及时更新,可以打开IDEA的file/setting/Build, Execution, Develoyment/Build Tools/Maven选中Always update snapshots
更新快照的最新版本可以在这里查看(替换红色部分)
https://oss.sonatype.org/content/repositories/snapshots/org/anyline/anyline-core/8.7.1-SNAPSHOT/maven-metadata.xml
看其中任意一个snapshotVersion.value如<value>8.7.1-20240110.042344-92</value>应该与本地文件名一致
对照本地maven仓库中的org\anyline\anyline-core\8.7.1-SNAPSHOT\anyline-core-8.7.1-20240110.042344-92.jar

与jdk,spring版本的对应关系

anyline jdk spring spring boot
8.7.1 8 5 2
8.7.1-jdk17 17 6 3
8.7.1-jdk21 21 6 3

最近更新 搜索 提交